Epic Browser Issue – Auto-Pinning and Re-Creating Shortcut icon in some Win64 Systems

Have you tried to delete the Epic shortcut icon from your desktop only to find it re-appear? Have you un-pinned Epic from your taskbar only to find it re-pinned some time later?

phpebS77FAM

Sorry about that Windows 64 bit users!

It turns out this problem is related to the chromium installer/updater only for Windows 64 bit systems. We’ve ripped out *a lot* that was unnecessary/potentially tracking-related in the chromium installer/updater, and that inadvertently led to this issue with Win64 installations. What happens is that the installer keeps thinking that it’s a fresh install and thus creates the shortcut icon and pins the icon to the taskbar if they’re not there. We’ve been working considerably to try to update the updater/installer to fix this, but we haven’t been able to accomplish this. So though we’re still working on this solution, we recommend users irritated by this to uninstall Epic/re-install a fresh download of Epic.

Windows 64 bit users facing this issue, here are the steps to take at present to solve this issue.  You’ll have to uninstall then re-install the latest Epic.  This takes less than a minute but please backup passwords/bookmarks before uninstalling Epic.

[optional] Backup Passwords & Bookmarks.  Open a window navigator, then type %localappdata% and press return. Then open the “Epic Privacy Browser” folder, then open the “User Data” folder, then open the “Default” folder.  Then copy the files (not the folders) in the “Default” folder — particularly “Bookmarks” “Bookmarks.bak” “Login Data” “Login Data.journal” “TransportSecurity” “Preferences” and any other files there.  Copy those files into some safe folder on your system!!

[1] Uninstall Epic. At the bottom of the Epic menu there’s an “Uninstall” option (or you can use the Windows uninstall method).
[2] Delete Epic Folders. After you uninstall Epic, to be even more safe, please delete the “Epic Privacy Browser” folder in case it’s still there — to do this, open a window navigator, then type %localappdata% and press return. Then delete the “Epic Privacy Browser” folder if it is there. Then check if you have an additional folder named “Epic”, if so, then open it and see if you have these folders: crash reports folder and update folder. If you do, please delete both folders. [Note: the chromium uninstall process is surprisingly not very thorough (not sure why), but we've cleaned it up considerably with the latest Epic.]
[3] Download and Install Latest Epic. Download the latest epic from epicbrowser.com and install it.

[optional]  Import Bookmarks and Passwords Files.  Open a window navigator, then type %localappdata% and press return. Then open the “Epic Privacy Browser” folder, then open the “User Data” folder, then open the “Default” folder.  Then copy the files (not the folders) you had previously copied/backed up into the “Default” folder

Thanks to many users for relaying this issue to us.  Sorry again for any inconvenience.  Since Epic’s release, we’ve solved over three dozen bugs and issues…many thanks to your feedback and many contributions in our forum (forum.epicbrowser.com).

Comments
  1. Andrew
    • Deatresa
  2. Bill Anderson
    • alok
  3. Arup Ghosh
  4. solkol08
    • alok
  5. Surajit
  6. Kiki
  7. Tom
  8. Anindya Basu
  9. jay
  10. google.com
    • Sai
  11. Chad
    • alok
  12. William Anderson
    • alok
  13. Jak
  14. Jiten Sahu

Leave a Reply

Your email address will not be published.


× 4 = thirty two